More fun with Erwin…

Después de varios meses detectando diversos errores en el Erwin, nos decidimos a actualizar a la última versión (7.3.11). El procedimiento es sencillo: te bajas el fichero con la actualización (CAEDM73pr11-b2812.exe) y lo instalas. Pero ni por una apuesta: el fichero descargado se niega a arrancar, da errores varios y después de indagar parece ser que se debe a que el fichero está corrupto (suponemos que durante el proceso de descarga). Lo siguiente sería gracioso si no fuera tan triste: tres descargas sucesivas nos dan tres ficheros con tres tamaños diferentes, y ninguno funciona.

Así que recurrimos a una actualización anterior (7.3.8) procedente de un CD. Este fichero (CAEDM738sp2-b2235a.exe) sí arranca y se ejecuta al parecer sin prioblemas, pero enseguida vemos los nubarrones en el horizonte: dice que va a instalarse en una ruta diferente a la que existe actualmente en el equipo (es decir: no ha detectado la instalación previa ¡¿?!). Modifico manualmente la ruta de instalación al directorio donde está instalada la versión anterior y comienza el proceso de instalación…

Tras un buen rato, el instalador dice que todo ha ido OK. En efecto: arranco el Erwin Data Modeler y parece que funciona. En el Help/About aparece la versión 7.3.8.2235 (Service Pack 2).

Pero claro, la cosa no podía tener un final feliz. Al intentar abrir un modelo creado con la versión original ocurre que aparece una ventanita ‘Post Load Ugrade’ con el mensaje ‘The upgrade failed to complete.’ y los detalles: ‘A model processor could not be found blah, blah, blah…’:

Error Erwin 1

Error Erwin 1

Para enseguida mostrar:

Error Erwin 2

Error Erwin 2

Busco en la base de conocimiento de soporte de erwin y encuentro:

Title:  When opening a model I get an error: ‘Model Processor could not be found’ and the model does not open. It works fine on another PC, but not on this one. Why do I get this error?
That error is most likely due to a version incompatibility. The model being opened is from a later version, so you will need to upgrade to the compatible version.

O sea, que interpreta que el modelo creado con la versión original (7.3.5) es posterior a la recién instalada (7.3.8) (¿¡!?)

Por otra parte, no se ofrece ninguna solución, ni ‘workaround’, ni nada de nada…

Así que, ¿ahora qué hacemos, señores de ca?

Saludos.

Carlos.

Anuncios

Una respuesta a More fun with Erwin…

  1. […] cuantas horas de indagaciones y pruebas ensayo-error, me condujeron a dar con la solución del molesto error tras la actualización de Erwin. Resulta que en el directorio de instalación deben existir unos ficheros que son los que permiten […]

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: