zypper y la actualización obstinada.

Software Updates” en mi openSuSE 42.1 Leap me avisaba de una actualización pendiente:

“openSuSE-2016-1453 Security update for Chromium”

Pero cada vez que intentaba la actualización se producía un fallo y me indicaba que los detalles del problema estaban en el “detailed report“. Report que, por otra parte, fui incapaz de encontrar. Y así una y otra vez.

Así que, harto del dichoso mensajito de error, me fui a la documentación: zypper.

Gestión de actualizaciones:
...
patch                   Instalar los parches necesarios.

Con esto:

carlos@OpenSuSE42:~> sudo zypper patch
root's password:
Cargando datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias de paquete...

Problema: patch:openSUSE-2016-1453-1.noarch está en conflicto con chromium.x86_64 < 55.0.2883.75-99.2 
          proporcionado por chromium-54.0.2840.100-91.1.x86_64 
 Solución 1: instalar chromium-55.0.2883.75-99.2.x86_64 (con cambio de proveedor) http://packman.links2linux.de -->  openSUSE
 Solución 2: no instalar patch:openSUSE-2016-1453-1.noarch

Choose from above solutions by number or cancel [1/2/c] (c): 1
Resolviendo dependencias...
Resolviendo dependencias de paquete...

The following application is going to be installed:
  Chromium

The following 3 NEW packages are going to be installed:
  libre2-0 libsnappy1 libwebpdemux1

The following NEW patch is going to be installed:
  openSUSE-2016-1453

The following package is going to be REMOVED:
  chromium-ffmpeg

The following package is going to be upgraded:
  chromium

1 package to upgrade, 3 new, 1 to remove.
Tamaño total de descarga: 50,3 MiB. Ya en caché: 0 B. Después de la operación, se liberarán 900,2 KiB.
¿Desea continuar? [s/n/? mostrar todas las opciones] (s): s
Recuperando package libsnappy1-1.1.3-1.1.x86_64            (1/4),  19,8 KiB ( 33,0 KiB desempaquetado)
Recuperando: libsnappy1-1.1.3-1.1.x86_64.rpm ..................................[TERMINADO (1,9 KiB/s)]
Recuperando package libre2-0-20161101-2.1.x86_64           (2/4), 143,4 KiB (411,9 KiB desempaquetado)
Recuperando: libre2-0-20161101-2.1.x86_64.rpm ...............................[TERMINADO (286,7 KiB/s)]
Recuperando package libwebpdemux1-0.4.3-7.1.x86_64         (3/4),  13,8 KiB ( 14,1 KiB desempaquetado)
Recuperando: libwebpdemux1-0.4.3-7.1.x86_64.rpm ...........................................[TERMINADO]
Recuperando package chromium-55.0.2883.75-99.2.x86_64      (4/4),  50,1 MiB (193,3 MiB desempaquetado)
Recuperando: chromium-55.0.2883.75-99.2.x86_64.rpm ..........................[TERMINADO (610,3 KiB/s)]
Buscando conflictos de archivos: ..........................................................[TERMINADO]
(1/4) Instalando: libsnappy1-1.1.3-1.1.x86_64 .............................................[TERMINADO]
(2/4) Instalando: libre2-0-20161101-2.1.x86_64 ............................................[TERMINADO]
(3/4) Instalando: libwebpdemux1-0.4.3-7.1.x86_64 ..........................................[TERMINADO]
(4/4) Instalando: chromium-55.0.2883.75-99.2.x86_64 .......................................[TERMINADO]
carlos@OpenSuSE42:~> 

Una vez hecho esto, la famosa actualización “openSuSE-2016-1453 Security update for Chromium” no me ha vuelto a molestar…

He aquí una pequeña magia de zypper: te detecta los problemas, te indica las soluciones a elegir y ejecuta la que tú le digas.

Saludos.

Carlos.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: